about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-31T12·45+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-31T13·20+0000
commitedea127e07fddf9f25e53323d098c0b9168cb3d2 (patch)
tree2fb06af9dda4b60f9a70c146f13a0b56ddcd87df /emacs/default.nix
parent039b260cacd1880044b0f9fe8a1b0729ee4ebb06 (diff)
Support building wpcarros-emacs
I'm using a Makefile until I can remember the command:

```shell
> nix-env -f . -i
```

This will install (i.e. `-i`) any derivations instantiated from the Nix
expression resolvable by `-f`. Ideally the incantation will look something like
this:

```shell
> nix-env -f '<universe>' -iA emacs
```

Informing `nix-env` to install all of the derivations created by the expression
at attribute `emacs` in my `<universe>` repository. For now two things are
preventing this:

1. `emacs` isn't an attribute in my top-level expression defined in the
   `default.nix`.
2. If I do add `emacs` as an attribute and call the above command, my usage of
   `readTree` results in `pkgs` missing `.lib` and a few other stdlib commands
   that are available in `(import <nixpkgs> {})`.

A fix for both of these should be forthcoming.
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index 9ff5c1f2df..18d9f2cc61 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -36,6 +36,12 @@ let
       neotree # TODO: Remove this dependency from my config.
       which-key
       ivy
+      restclient
+      package-lint
+      parsec
+      magit-popup
+      direnv
+      emr
       ivy-prescient
       all-the-icons
       all-the-icons-ivy