about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-11-12T11·20+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-11-12T11·20+0000
commitd2d772e43e0d4fb1bfaaa58d7de0c9e2cc274a25 (patch)
treebbbb05e1e97bade309e69197325ecb29e268671b /emacs/default.nix
parent6d26f5b987ee39253370b163be6fb264bb9bcae9 (diff)
Sort Emacs deps
Group Emacs dependencies like ivy together.
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index b5d44a251a..2964288ebe 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -47,7 +47,6 @@ let
       vterm
       base16-theme
       password-store
-      ivy-pass
       clipmon # TODO: Prefer an Emacs client for clipmenud.
       evil
       evil-collection
@@ -65,15 +64,16 @@ let
       doom-themes
       telephone-line
       which-key
+      all-the-icons
+      all-the-icons-ivy
       ivy
+      ivy-pass
+      ivy-prescient
       restclient
       package-lint
       parsec
       magit-popup
       direnv
-      ivy-prescient
-      all-the-icons
-      all-the-icons-ivy
       alert
       nix-mode
       racer
@@ -121,7 +121,6 @@ let
       company
       counsel
       flycheck
-      ivy
     ]));
 
   vendorDir = path {
@@ -129,6 +128,7 @@ let
     name = "emacs-vendor";
   };
 
+  # TODO: byte-compile these by packaging each as an Elisp library.
   wpcDir = path {
     path = ./.emacs.d/wpc;
     name = "emacs-libs";
@@ -160,10 +160,10 @@ let
       export EMACSLOADPATH="${loadPath}"
       exec ${emacsBin} \
         --debug-init \
+        --no-init-file \
         --no-site-file \
         --no-site-lisp \
         --load ${initEl} \
-        --no-init-file \
         "$@"
     '';
 in {