about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-09-07T18·49+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-09-07T18·49+0100
commit2edcaca6b47e6adb98020545fd89a3516377cae9 (patch)
treec1f1c621c691d33703f407e4c696cf0c8f41679f /emacs/default.nix
parent88a683e4080c60bd75c495557fb8e2d52932aac2 (diff)
Expose path to GOOGLE_BRIEFCASE as env var
After ~1-2 hours of debugging, I realized that locally I was reading from .envrc
but when Emacs initializes, it is not reading from .envrc. I don't know how to
ideally handle this, so for now I'm including GOOGLE_BRIEFCASE as an environment
variable and moving on with my life.
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index 062bb5ee28..ff4e4cad88 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -144,6 +144,7 @@ let
     writeShellScriptBin "wpcarros-emacs" ''
       export XMODIFIERS=emacs
       export BRIEFCASE=${briefcasePath}
+      export GOOGLE_BRIEFCASE="$HOME/google-briefcase"
       export PATH="${emacsBinPath}:$PATH"
       export EMACSLOADPATH="${loadPath}"
       exec ${emacsBin} \