about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-23T22·29+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-01T22·32+0000
commit9e0fdd397382da10a8486d25cfa9d889fdd17f86 (patch)
treec1d097f0ecb1a5366dd22989c2beda9c853dd482 /emacs/default.nix
parentfd720fbe4d284d0562ab32e7bb6a3f7171992c21 (diff)
Remove default values for Nix expression parameters
I'm not sure if this commit breaks everything in my monorepo. I think it
will.

Why am I doing this? Perhaps it's a bad idea. I don't fully understand how
readTree works. My ignorance is costing me hours of time spent debugging. In an
effort to better understand readTree, I'm removing the default values for my Nix
expression parameters, which I believe have preventing errors from surfacing.
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix8
1 files changed, 2 insertions, 6 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index a61d6fb702..094b1c3db6 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -1,11 +1,7 @@
-{
-  pkgs ? import <nixpkgs> {},
-  depot ? import <depot> {},
-  ...
-}:
+{ pkgs, depot, ... }:
 
 let
-  utils = import ~/briefcase/utils;
+  utils = import <briefcase/utils>;
   # NOTE: I'm trying to keep the list of dependencies herein constrained to a
   # list of generic dependencies (i.e. not project or language specific). For
   # language-specific tooling, I'm intending to use shell.nix alongside lorri