about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-06T22·23+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-07T11·01+0000
commit048b7867bfd6c1dc45bb2dac840e714c5901af36 (patch)
treebb2447381e6c6ead13cbb5fa83094749efe179b6 /emacs/default.nix
parentc15a393112e1b7ead683955148fa527c0d28160f (diff)
Add bin dependencies to wpcarros-emacs
I removed most of the packages that I install with `nix-env`. You can view these
with `nix-env --query`. This is one small step in a grander project to migrate
entirely to a declarative config managed by Nix.
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix22
1 files changed, 20 insertions, 2 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index 4e025ec1c0..1635c0286f 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -6,11 +6,29 @@
 
 let
   utils = import ~/briefcase/utils;
+  # NOTE: I'm trying to keep the list of dependencies herein constrained to a
+  # list of generic dependencies (i.e. not project or language specific). For
+  # language-specific tooling, I'm intending to use shell.nix alongside lorri
+  # and direnv.
   emacsBinPath = pkgs.lib.strings.makeBinPath (with pkgs; [
+    lorri
+    direnv
+    tdesktop # native telegram client
+    diskus
+    bat
+    exa
+    fd
+    fzf
+    tldr
+    tokei
+    nmap
+    ripgrep
+    gitAndTools.hub
+    kubectl
+    google-cloud-sdk
+    xsv
     scrot
     clipmenu
-    ocaml
-    ocamlformat
   ]);
   emacsWithPackages = (pkgs.emacsPackagesNgGen pkgs.emacs26).emacsWithPackages;
   wpcarrosEmacs = emacsWithPackages (epkgs: