about summary refs log tree commit diff
path: root/emacs/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-06T21·44+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-07T11·01+0000
commit52d284f59d711a31efba97ca192b60a7be9bfbdb (patch)
treeecf0480b794f45a03d6f2c650bb7ef3e5ebba40d /emacs/default.nix
parentb47ca8b8769883557ac1ef62a6fb1cd815f08fb6 (diff)
Remove assertions that prelude/executable-exists?
I'm in the midst of transitioning onto a few new tools.

My previous workflow just used `nix-env` to install *some* packages. I didn't
have a prescribed methodology for which packages I would install using `nix-env`
and which ones I would install using `sudo apt-get install`. Sometimes if a
package would be available in my aptitude repositories, I'd use that; other
times when it wasn't available I'd use `nix-env`. One complication about being
on gLinux intead of NixOS is that some packages (e.g. nixpkgs.terminator) is
available via `nix-env -iA nixpkgs.terminator`, but the installation won't
actually run on my gLinux. In these instances, I would install terminator from
the aptitude repositories.

Then @tazjin introduced me to his Emacs configuration that he builds using
Nix. What appealed to me about his built Emacs is that it worked as expected on
either a NixOS machine and on gLinux (and presumably on other non-NixOS machines
as well).

A setup towards which I'm working is to own one or a few NixOS machines whose
configurations are entirely managed with Nix. On devices like my work machines,
which cannot run NixOS, I can build as much of the software that I need using
Nix and attempt to minimize the ad hoc configuration either with shell scripts,
python, golang, or more Nix code... it's clear that I still don't have a clear
idea of how that part will work.

For now, I'm adopting nix, nix-env, lorri, direnv, and weening off of aptitude
as much as I can. Things are a bit messy, but my general trend feels
positive. Stay tuned for more updates.
Diffstat (limited to 'emacs/default.nix')
-rw-r--r--emacs/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/emacs/default.nix b/emacs/default.nix
index 24496bccc1..4e025ec1c0 100644
--- a/emacs/default.nix
+++ b/emacs/default.nix
@@ -6,7 +6,12 @@
 
 let
   utils = import ~/briefcase/utils;
-  emacsBinPath = pkgs.lib.strings.makeBinPath [ pkgs.terminator ];
+  emacsBinPath = pkgs.lib.strings.makeBinPath (with pkgs; [
+    scrot
+    clipmenu
+    ocaml
+    ocamlformat
+  ]);
   emacsWithPackages = (pkgs.emacsPackagesNgGen pkgs.emacs26).emacsWithPackages;
   wpcarrosEmacs = emacsWithPackages (epkgs:
     (with epkgs.elpaPackages; [