about summary refs log tree commit diff
path: root/emacs.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-08-05T14·13+0200
committerVincent Ambo <tazjin@gmail.com>2018-08-05T14·13+0200
commit1f3835d60cdea042094404cac5f299152f681da2 (patch)
tree77222e7ab1bf4629ff606813ac7e906765e96939 /emacs.nix
parent178558cea0eb6f7d0648d44fabdda6a540d4ea05 (diff)
chore(emacs): Override EXWM version with potential bug fix
Overrides the EXWM version from the latest released one to a current
commit in master that may constitute a fix for ch11ng/exwm#425
Diffstat (limited to 'emacs.nix')
-rw-r--r--emacs.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/emacs.nix b/emacs.nix
index cef66240375e..365bfc707a04 100644
--- a/emacs.nix
+++ b/emacs.nix
@@ -153,6 +153,19 @@ sly = emacsPackagesNg.melpaBuild {
   '';
 };
 
+# EXWM pinned to a newer version than what is released due to a
+# potential fix for ch11ng/exwm#425.
+exwm = emacsPackagesNg.exwm.overrideAttrs(_: {
+  version = "master";
+
+  src = fetchFromGitHub {
+    owner  = "ch11ng";
+    repo   = "exwm";
+    rev    = "aebcb0344f18b1aa284a432811175fde2d2feae5";
+    sha256 = "0niwbzim029lg71y5rrg607zfiw1zmhk7zcyk5874gbrkfmyr52b";
+ };
+});
+
 in emacsWithPackages(epkgs:
   # Actual ELPA packages (the enlightened!)
   (with epkgs.elpaPackages; [
@@ -177,7 +190,6 @@ in emacsWithPackages(epkgs:
     edit-server
     elixir-mode
     erlang
-    exwm
     go-mode
     gruber-darker-theme
     haskell-mode
@@ -215,5 +227,5 @@ in emacsWithPackages(epkgs:
   (lib.attrValues newIvy) ++
 
   # Custom packaged Emacs packages:
-  [ nix-mode eglot prescient ivy-prescient counsel-notmuch pkgs.notmuch sly ]
+  [ nix-mode eglot prescient ivy-prescient counsel-notmuch pkgs.notmuch sly exwm ]
 )