about summary refs log tree commit diff
path: root/emacs.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2018-06-29T11·06+0200
committerVincent Ambo <mail@tazj.in>2018-06-29T11·06+0200
commit40f78045768b51b8dfed649ca58e26c1803e0b63 (patch)
tree903bbe6faeeba9dcdeb296577c31a472f29490cf /emacs.nix
parentd14bc8e2931d5fae6ac5be3513bd091211ebae26 (diff)
feat(emacs): Install counsel-notmuch
Diffstat (limited to 'emacs.nix')
-rw-r--r--emacs.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/emacs.nix b/emacs.nix
index 5ff20d75a4..a60cfed4cc 100644
--- a/emacs.nix
+++ b/emacs.nix
@@ -79,6 +79,23 @@ newIvy.ivy-pass = melpaBuild {
   };
 };
 
+counsel-notmuch = melpaBuild {
+  pname   = "counsel-notmuch";
+  version = "20171223";
+
+  packageRequires = [
+    newIvy.ivy
+    pkgs.notmuch
+  ];
+
+  src = fetchFromGitHub {
+    owner  = "fuxialexander";
+    repo   = "counsel-notmuch";
+    rev    = "ac1aaead81c6860d7b8324cc1c00bcd52de5e9ca";
+    sha256 = "19frcrz6bx7d7v1hkg0xv7zmbk2sydlsdzn1s96cqzjk1illchkz";
+  };
+};
+
 # prescient & ivy-prescient provide better filtering in ivy/counsel,
 # but they are not in nixpkgs yet:
 prescientSource = fetchFromGitHub {
@@ -188,5 +205,5 @@ in emacsWithPackages(epkgs:
   (lib.attrValues newIvy) ++
 
   # Custom packaged Emacs packages:
-  [ nix-mode eglot prescient ivy-prescient pkgs.notmuch sly ]
+  [ nix-mode eglot prescient ivy-prescient counsel-notmuch pkgs.notmuch sly ]
 )