about summary refs log tree commit diff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-01-08T10·45+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-01-08T10·45+0000
commit5346536b626a047d53f9c44d6562cfaeffe27f14 (patch)
tree980c46eb8797733473d6d0685e2d2c088c038629 /doc/manual/Makefile.am
parent7959354379416bd8513cb00e636c0310e42eaa01 (diff)
* Include version number in manual.
Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
index 595773f1cdbc..8f4c84790613 100644
--- a/doc/manual/Makefile.am
+++ b/doc/manual/Makefile.am
@@ -11,10 +11,13 @@ SOURCES = manual.xml introduction.xml installation.xml overview.xml \
  troubleshooting.xml bugs.xml \
  style.css images
 
-manual.is-valid: $(SOURCES)
+manual.is-valid: $(SOURCES) version.xml
 	$(XMLLINT) --noout --valid manual.xml
 	touch $@
 
+version.xml:
+	echo -n $(VERSION) > version.xml
+
 man1_MANS = nix-store.1 nix-instantiate.1
 
 man $(MANS): $(SOURCES) manual.is-valid
@@ -38,6 +41,8 @@ images:
 	cp $(docbookxsl)/images/callouts/*.png images/callouts
 	chmod +w -R images
 
-EXTRA_DIST = $(SOURCES) manual.html manual.is-valid $(MANS) 
+KEEP = manual.html manual.is-valid version.xml $(MANS)
+
+EXTRA_DIST = $(SOURCES) $(KEEP)
 
-DISTCLEANFILES = manual.html manual.is-valid $(MANS)
+DISTCLEANFILES = $(KEEP)