about summary refs log tree commit diff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-11-26T11·24+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-11-26T11·24+0000
commit2a4bac5459f42764b39ac70f906f5dd3330a3ac5 (patch)
treebbfd82cfe6e081bd0f83722e9c3aa3abd9f831c3 /doc/manual/Makefile.am
parentbd0ce1a4be6612cf53d9d31f1cbe1b25085ccf75 (diff)
* Refactoring.
* Convert tabs to spaces.

Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
index 8b3060ac7245..8e2fff208747 100644
--- a/doc/manual/Makefile.am
+++ b/doc/manual/Makefile.am
@@ -3,16 +3,17 @@ ENV = SGML_CATALOG_FILES=$(docbookcatalog)
 XMLLINT = $(ENV) $(xmllint) $(xmlflags) --catalogs
 XSLTPROC = $(ENV) $(xsltproc) $(xmlflags) --catalogs
 
-SOURCES = book.xml introduction.xml installation.xml nix-reference.xml \
+SOURCES = book.xml introduction.xml installation.xml \
+ nix-store-reference.xml \
  troubleshooting.xml bugs.xml
 
 book.is-valid: $(SOURCES)
 	$(XMLLINT) --noout --valid book.xml
 	touch $@
 
-man1_MANS = nix.1 fix.1
+man1_MANS = nix-store.1 nix-instantiate.1
 
-man nix.1 fix.1: $(SOURCES) book.is-valid
+man $(MANS): $(SOURCES) book.is-valid
 	$(XSLTPROC) $(docbookxsl)/manpages/docbook.xsl book.xml
 
 book.html: $(SOURCES) book.is-valid
@@ -24,4 +25,6 @@ install-data-local: book.html
 	$(INSTALL) -d $(datadir)/nix/manual
 	$(INSTALL_DATA) book.html $(datadir)/nix/manual
 
-EXTRA_DIST = $(SOURCES) book.html nix.1 fix.1 book.is-valid
+EXTRA_DIST = $(SOURCES) book.html book.is-valid $(MANS) 
+
+DISTCLEANFILES = book.html book.is-valid $(MANS)