about summary refs log tree commit diff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-08-12T13·54+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-08-12T13·54+0000
commite405ca506efa608c3636023a98994c05f09ecf0c (patch)
tree0875328cfb44957a693d92f0d56037f2967a4642 /doc/manual/Makefile.am
parentc602930e08a508fce76b16f6f7f1fdfaed3b91ab (diff)
* Generate man pages from the manual.
Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
new file mode 100644
index 0000000000..a4e3f24cee
--- /dev/null
+++ b/doc/manual/Makefile.am
@@ -0,0 +1,22 @@
+DOCBOOK_DTD = /nix/current/xml/dtd/docbook
+DOCBOOK_XSL = /nix/current/xml/xsl/docbook
+XML = /usr/share/doc/packages/sp/html-xml/xml.soc
+
+%.is-valid: %.xml
+	SP_CHARSET_FIXED=YES SP_ENCODING=XML \
+	nsgmls -wxml -c $(XML) -c $(DOCBOOK_DTD)/docbook.cat -ges $<
+	touch $@
+
+man1_MANS = nix.1
+
+man nix.1: book.is-valid
+	xsltproc $(DOCBOOK_XSL)/manpages/docbook.xsl book.xml
+
+%.html: %.xml %.is-valid
+	xsltproc --output book.html $(DOCBOOK_XSL)/html/docbook.xsl book.xml
+
+all-local: book.html
+
+install-data-local: book.html
+	$(INSTALL) -d $(datadir)/nix/manual
+	$(INSTALL_DATA) book.html $(datadir)/nix/manual