about summary refs log tree commit diff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-08-13T09·13+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-08-13T09·13+0000
commitb4f88d0ec364f00196127ea29e8db5033368e23a (patch)
treefad418cdf09bd63cdc932b9b25531b75f55eaa29 /doc/manual/Makefile.am
parent469f1eba561403639e777721cacd59e0a6cdc39d (diff)
* Split the book.xml into several xml files.
Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
index a4e3f24cee..a29592f1e1 100644
--- a/doc/manual/Makefile.am
+++ b/doc/manual/Makefile.am
@@ -2,17 +2,20 @@ DOCBOOK_DTD = /nix/current/xml/dtd/docbook
 DOCBOOK_XSL = /nix/current/xml/xsl/docbook
 XML = /usr/share/doc/packages/sp/html-xml/xml.soc
 
-%.is-valid: %.xml
+SOURCES = book.xml introduction.xml installation.xml nix-reference.xml \
+ troubleshooting.xml bugs.xml
+
+book.is-valid: $(SOURCES)
 	SP_CHARSET_FIXED=YES SP_ENCODING=XML \
 	nsgmls -wxml -c $(XML) -c $(DOCBOOK_DTD)/docbook.cat -ges $<
 	touch $@
 
 man1_MANS = nix.1
 
-man nix.1: book.is-valid
+man nix.1: $(SOURCES) book.is-valid
 	xsltproc $(DOCBOOK_XSL)/manpages/docbook.xsl book.xml
 
-%.html: %.xml %.is-valid
+book.html: $(SOURCES) book.is-valid
 	xsltproc --output book.html $(DOCBOOK_XSL)/html/docbook.xsl book.xml
 
 all-local: book.html