about summary refs log tree commit diff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2005-09-14T18·50+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2005-09-14T18·50+0000
commit025086edeaa6fc39ee8b5bc6fcad3cc64c2fd0c2 (patch)
treeff3ea5af8d1f5f096cbec6148e9001565f1d3fed /doc/manual/Makefile.am
parented1db42915dc13cff9b940ae2b12ff9e38b28961 (diff)
* Release notes in Docbook; ASCII release notes (i.e., the `NEWS'
  file) is now generated from that using `w3m' and some XSL hackery.

Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
index 81367fd141..2cc3766120 100644
--- a/doc/manual/Makefile.am
+++ b/doc/manual/Makefile.am
@@ -37,7 +37,24 @@ manual.html: $(MANUAL_SRCS) manual.is-valid images
 	$(XSLTPROC) --nonet --xinclude --output manual.html \
 	  $(docbookxsl)/html/docbook.xsl manual.xml
 
-all-local: manual.html
+
+NEWS_OPTS = \
+ --stringparam generate.toc "article nop" \
+ --stringparam section.autolabel.max.depth 0 \
+ --stringparam header.rule 0
+
+NEWS.html: release-notes.xml
+	$(XSLTPROC) --nonet --xinclude --output $@ $(NEWS_OPTS) \
+	  $(docbookxsl)/html/docbook.xsl release-notes.xml
+
+NEWS.txt: release-notes.xml
+	$(XSLTPROC) --nonet --xinclude quote-literals.xsl release-notes.xml | \
+	  $(XSLTPROC) --nonet --output $@.tmp.html $(NEWS_OPTS) \
+	  $(docbookxsl)/html/docbook.xsl -
+	w3m -dump $@.tmp.html > $@
+
+
+all-local: manual.html NEWS.html NEWS.txt
 
 install-data-local: manual.html
 	$(INSTALL) -d $(DESTDIR)$(datadir)/nix/manual