about summary refs log tree commit diff
path: root/desktop.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2018-09-16T14·52+0200
committerVincent Ambo <mail@tazj.in>2018-09-16T14·57+0200
commit8d918e48eb1975a7fb477bac7ec7d4a06df6d3c9 (patch)
treedbe66feb9f6b2d41b2e8837ab8f5ee682a72c214 /desktop.nix
parent754b487ee4dfa0cbf3cb3c9a680d4b0675692d4e (diff)
refactor(desktop): Don't launch EXWM via Emacs client
Launch EXWM directly in Emacs, instead of first launching an Emacs
server and connecting a client.

In cases where Emacs does not start correctly due to initialisation
errors the error message would never become visible without this change.
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/desktop.nix b/desktop.nix
index 56027e4397f0..61d2482c446e 100644
--- a/desktop.nix
+++ b/desktop.nix
@@ -29,8 +29,7 @@ in {
   services.xserver.windowManager.session = lib.singleton {
     name = "exwm";
     start = ''
-      ${emacs}/bin/emacs --daemon -f exwm-enable
-      ${emacs}/bin/emacsclient -c
+      ${emacs}/bin/emacs --eval '(progn (server-start) (exwm-enable))'
     '';
   };