about summary refs log tree commit diff
path: root/desktop.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-03-03T23·07+0100
committerVincent Ambo <tazjin@gmail.com>2018-03-03T23·07+0100
commit95eedea9ac2763f43fad0643d3a35a76227aea47 (patch)
treebf9fd0a07cba0e9dd8a2c0de08e4467b5d331103 /desktop.nix
parent9042d0a9870469aee9c75cfbf142e9ef11f39011 (diff)
feat(emacs): Install required emacs packages via Nix
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/desktop.nix b/desktop.nix
index b306cd5196cc..bb3041f1c56f 100644
--- a/desktop.nix
+++ b/desktop.nix
@@ -3,6 +3,7 @@
 { config, lib, pkgs, ... }:
 
 let wallpapers = import ./pkgs/wallpapers.nix;
+    emacs = import ./emacs.nix { inherit pkgs; };
 in {
   # Configure basic X-server stuff:
   services.xserver = {
@@ -23,8 +24,8 @@ in {
   services.xserver.windowManager.session = lib.singleton {
     name = "exwm";
     start = ''
-      ${pkgs.emacs}/bin/emacs --daemon -f exwm-enable
-      emacsclient -c
+      ${emacs}/bin/emacs --daemon -f exwm-enable
+      ${emacs}/bin/emacsclient -c
     '';
   };