about summary refs log tree commit diff
path: root/desktop.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2017-10-20T21·22+0200
committerVincent Ambo <tazjin@gmail.com>2017-10-20T22·05+0200
commit7fe75e01386f24385ae9ccc624e3d8561df8bcbb (patch)
treeb72d47b17c2006a5f103da3e1c4d53552b35b26c /desktop.nix
parenta8a9bf130048ec1c71ed44a3930da0bd13c626d8 (diff)
feat(dotfiles): Begin controlling various dotfiles from Nix
Moves my i3 configuration into a nix derivation called 'tazjins-dotfiles'.

A good step towards fully declarative system configuration!
Diffstat (limited to 'desktop.nix')
-rw-r--r--desktop.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/desktop.nix b/desktop.nix
index 541d1a458049..85e9f4b9a8c6 100644
--- a/desktop.nix
+++ b/desktop.nix
@@ -10,7 +10,11 @@ in {
   services.xserver.xkbOptions = "caps:super, grp:shifts_toggle";
 
   # configure desktop environment:
-  services.xserver.windowManager.i3.enable = true;
+  services.xserver.windowManager.i3 = {
+    enable = true;
+    configFile = "/etc/i3/config";
+  };
+
   services.compton.enable = true;
   services.compton.backend = "xrender"; # this should be the default!