about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-12-16T16·15+0100
committersterni <sternenseemann@systemli.org>2021-12-16T18·11+0000
commitfaca687dda83d5c7eaf0d6daaddd4b5db3aebbe0 (patch)
tree84d96883c3e19b57dfd398b701735c8a5eb0c9a5 /default.nix
parent3bf3f9510562e98b51d6f771f2f37dc88f165af2 (diff)
fix: make sure depot.path is named "depot" (again) r/3268
It is a reasonable enough assumption that depot.path will have the store
path name "depot". In the past this used to be the case, since most
people would checkout the repository as "depot" (funnily enough in the
past, you wouldn't have been able to substitute some things if you used
a different name). When we started to use cleanSource for depot.path the
default name "source" would be assigned, breaking e. g. the assumptions
of //web/todolist. We now set to "depot" statically.

Fixes: b/162

Change-Id: I72fdb488e045bdaee80d1df0334b026060dcd116
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4381
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 7ccd7413db..9a73e99d89 100644
--- a/default.nix
+++ b/default.nix
@@ -87,7 +87,11 @@ in readTree.fix(self: (readDepot {
 }) // {
   # Make the path to the depot available for things that might need it
   # (e.g. NixOS module inclusions)
-  path = self.third_party.nixpkgs.lib.cleanSource ./.;
+  path = self.third_party.nixpkgs.lib.cleanSourceWith {
+    name = "depot";
+    src = ./.;
+    filter = self.third_party.nixpkgs.lib.cleanSourceFilter;
+  };
 
   # List of all buildable targets, for CI purposes.
   #