about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-12T20·26+0200
committertazjin <mail@tazj.in>2021-04-12T21·55+0000
commitf520bd40cab9bae4f8fa26fe36365a7bf9bccd5a (patch)
tree5f116d10e44b7f3616fb63c28e7de03d81869071 /default.nix
parenta5591359702b62e4edd7fdbbd135475037aa6727 (diff)
refactor: Replace 'depotPath' with 'depot.path' r/2497
Instead of having two ways of accessing the path to the depot (one of
which was stuttering, depot.depotPath) we settle on only one:
depot.path.

This was mostly used for NixOS module imports.

Co-Authored-By: Florian Klink <flokli@flokli.de>
Change-Id: I2c0db23383fc34f6ca76baaad4cc4af2d9dfae15
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2962
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/default.nix b/default.nix
index a73e46877a..d8b9b08b69 100644
--- a/default.nix
+++ b/default.nix
@@ -47,12 +47,7 @@ let
            (node.meta.targets or []))
     else [];
 
-  # Make the path to the depot available for things that might need it
-  # (e.g. NixOS module inclusions)
-  depotPath = ./.;
 in fix(self: (readTree' {
-  # TODO(tazjin): Settle on one way of using depotPath
-  inherit depotPath;
   depot = self;
 
   # Pass third_party as 'pkgs' (for compatibility with external
@@ -69,7 +64,9 @@ in fix(self: (readTree' {
   # debugging by bisecting nixpkgs.
   externalArgs = args;
 } ./.) // {
-  inherit depotPath;
+  # Make the path to the depot available for things that might need it
+  # (e.g. NixOS module inclusions)
+  path = ./.;
 
   # List of all buildable targets, for CI purposes.
   #