about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-19T17·57+0300
committertazjin <tazjin@tvl.su>2022-01-20T07·40+0000
commiteffcd31651c60e6bbd7db8e96a44d1278fa4bd39 (patch)
treea050333eb8bb6ba5c9a6f9dcf7ded00094ee0a11 /default.nix
parent0652ac0ace548ba6ea4b6b78fc7bbfee277ec5d0 (diff)
refactor: Replace 'meta.ci' -> 'meta.ci.skip' r/3638
We need 'meta.ci' to be an attribute set for new CI features.

Change-Id: I83d04e2d74e42e49fe739b049ee4ba799f6d5d86
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5007
Tested-by: BuildkiteCI
Reviewed-by: ezemtsov <eugene.zemtsov@gmail.com>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index db2c503559..bd2c6012fb 100644
--- a/default.nix
+++ b/default.nix
@@ -65,10 +65,10 @@ let
   # To determine build targets, we walk through the depot tree and
   # fetch attributes that were imported by readTree and are buildable.
   #
-  # Any build target that contains `meta.ci = false` will be skipped.
+  # Any build target that contains `meta.ci.skip = true` will be skipped.
 
   # Is this tree node eligible for build inclusion?
-  eligible = node: (node ? outPath) && (node.meta.ci or true);
+  eligible = node: (node ? outPath) && (!node.meta.ci.skip or true);
 
 in readTree.fix(self: (readDepot {
   depot = self;