about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-18T17·39+0000
committerVincent Ambo <tazjin@google.com>2019-12-18T17·39+0000
commitc776bd383da0e43d2f5ecbd2188590110507814c (patch)
tree1ab13a800704bba3a961c334577c408b775d210d /default.nix
parent3359ce12cfce249741dd034464e0967228cc4b34 (diff)
fix(build): Fix compatibility with Nixery instance r/183
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 0fd79b93fd..ea4101a1a5 100644
--- a/default.nix
+++ b/default.nix
@@ -54,4 +54,17 @@ in fix(self: {
 # This can be used to move things from third_party into the top-level, too (such
 # as `lib`).
 // (readTree' self.config) ./overrides
-)
+
+# These packages must be exposed at the top-level for compatibility
+# with Nixery.
+// {
+  inherit (self.third_party)
+    cacert
+    coreutils
+    iana-etc
+    jq
+    openssl
+    runCommand
+    symlinkJoin
+    writeText;
+})