about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-11-13T17·33+0100
committertazjin <mail@tazj.in>2021-11-15T12·54+0000
commitac41d89ba5d715918324c49630d0eac8283c4895 (patch)
tree5ca73b4474a2c26797a3ee319ed9ebdfaa395232 /default.nix
parentdc8d3e869d30f59c128877933f916475554e71cc (diff)
refactor(readTree): Flip argument order of argFilter r/3070
Since the filters return 'args', this makes nesting of filters more
readable.

Change-Id: I775252460e3e077cc6db2fab6f3948414a95ecbf
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3873
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 5c93e9501e..fcd83d07ad 100644
--- a/default.nix
+++ b/default.nix
@@ -20,7 +20,7 @@ let
   # Create a readTree filter disallowing access to the specified
   # top-level folder in other parts of the depot, except for specific
   # exceptions specified by their (full) paths.
-  restrictFolder = { folder, exceptions ? [], reason }: args: parts:
+  restrictFolder = { folder, exceptions ? [], reason }: parts: args:
     if (elemAt parts 0) == folder || elem parts exceptions
     then args
     else args // {