about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-13T20·39+0100
committertazjin <mail@tazj.in>2020-06-13T23·52+0000
commit9658e96a87178e972b656db0acf3219937013b88 (patch)
tree94c0821136dbc296d39fc03374c79924761f9626 /default.nix
parentcec109807babe65dba79b9776cee2024aad349a6 (diff)
feat: Add 'depotPath' to depot root import r/940
This is useful for things like including NixOS modules in
configurations without creating long and error-prone relative paths.

Change-Id: I4a5ebb1a0e5adf90b6bc50e884db453e12461001
Reviewed-on: https://cl.tvl.fyi/c/depot/+/243
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 9af5a8fe53..054b25b920 100644
--- a/default.nix
+++ b/default.nix
@@ -54,6 +54,10 @@ in fix(self: {
     __functor = x: (readTree' x.config);
     config = self.config;
   };
+
+  # Make the path to the depot available for things that might need it
+  # (e.g. NixOS module inclusions)
+  depotPath = ./.;
 }
 
 # Add local packages as structured by readTree