about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-20T20·37+0000
committerVincent Ambo <tazjin@google.com>2019-12-20T20·37+0000
commit8de5d093d8e35b2492c81015dcfcb052d2718614 (patch)
treef4bb5763a39c7059537fc7877e3c0ac15a4d8f69 /default.nix
parent03bfe08e1dd9faf48b06cb146bfa446575cde88a (diff)
refactor: Fix a variety of filepaths for repo relayouting r/238
This fixes readTree and the various project builds, as well
as (hopefully) most documentation links inside of the projects.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix34
1 files changed, 6 insertions, 28 deletions
diff --git a/default.nix b/default.nix
index 38de1be0de..34fd8dea2e 100644
--- a/default.nix
+++ b/default.nix
@@ -29,9 +29,12 @@ let
   readTree' = import ./read-tree.nix;
 
   localPkgs = readTree: {
-    services    = readTree ./services;
-    tools       = readTree ./tools;
+    fun         = readTree ./ops;
+    nix         = readTree ./nix;
+    ops         = readTree ./ops;
     third_party = readTree ./third_party;
+    tools       = readTree ./tools;
+    web         = readTree ./web;
   };
 in fix(self: {
   config = config self;
@@ -53,30 +56,5 @@ in fix(self: {
 #
 # This can be used to move things from third_party into the top-level, too (such
 # as `lib`).
-// (readTree' self.config) ./overrides
-
-# These packages must be exposed at the top-level for compatibility
-# with Nixery.
-// {
-  inherit (self.third_party)
-    bashInteractive
-    cacert
-    coreutils
-    iana-etc
-    jq
-    moreutils
-    nano
-    openssl
-    runCommand
-    symlinkJoin
-    writeText;
-}
-
-# These packages must be exposed for compatibility with buildGo.
-#
-# Despite buildGo being tracked in this tree, I want it to be possible
-# for external users to import it with the default nixpkgs layout.
-// {
-  inherit (self.third_party) go ripgrep;
-}
+// (readTree' { pkgs = self; }) ./overrides
 )