about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-08-26T23·11+0100
committertazjin <mail@tazj.in>2020-08-26T23·49+0000
commit4ff9d5dee86999b559da4b515ec12533787dc564 (patch)
tree0cb7d8d9fd8f7ba133a379f04179bce4c2e2cfad /default.nix
parent88317aea0d999e0933e4857660660ac408be03a0 (diff)
feat: Implement automatic CI target detection for the depot r/1725
Automatically walk the entire depot tree and pick out things that are
"buildable", then include them in the attribute `ci.targets` (which is
now also the target for CI builds).

A long time ago, in a land far away, we (well, I, at the time) had a
prototype of this which ran into constant issues with infinite
recursions while trying to walk the tree. In fact, this is why
readTree originally gained the `__readTree`-attribute which marks
things that were imported automatically.

Based on some code edef whipped up earlier (with the breakthrough
being that we also add the attribute to top-level folders, which
suddenly resolves a whole bunch of problems), I've now implemented
this actually working version.

At the moment all builds still happen as one big bag of builds, but at
some point we will granularise this.

Change-Id: I86f12ce7f63dae98e7e5c6646a4e9d220de783f2
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1854
Tested-by: BuildkiteCI
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix23
1 files changed, 21 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 13a9f5d588..b0b5399c4b 100644
--- a/default.nix
+++ b/default.nix
@@ -39,6 +39,22 @@ let
     users         = readTree ./users;
     web           = readTree ./web;
   };
+
+  # To determine build targets, we walk through the depot tree and
+  # fetch attributes that were imported by readTree and are buildable.
+  #
+  # Any build target that contains `meta.ci = false` will be skipped.
+
+  # Is this tree node eligible for build inclusion?
+  eligible = node: (node ? outPath) && (node.meta.ci or true);
+
+  # Walk the tree starting with 'node', recursively extending the list
+  # of build targets with anything that looks buildable.
+  gather = node:
+    if node ? __readTree then
+      (if eligible node then [node] else []) ++
+      concatMap gather (attrValues node)
+    else [];
 in fix(self: {
   config = config self;
 
@@ -55,8 +71,11 @@ in fix(self: {
   # (e.g. NixOS module inclusions)
   depotPath = ./.;
 
-  # Load CI builds in a way that can be injected into programs like besadii.
-  ciBuilds = import ./ci-builds.nix self.config;
+  # List of all buildable targets, for CI purposes.
+  #
+  # Note: This *must* be a nested attribute, otherwise we will get
+  # infinite recursion and everything blows up.
+  ci.targets = gather self;
 }
 
 # Add local packages as structured by readTree