about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-06-29T13·12+0100
committerVincent Ambo <tazjin@google.com>2019-06-29T13·12+0100
commit4cefb9256ac840f28409a7e0e5348465618a8bae (patch)
treeca87a1394804db59ec0e4f822bd860c7636eaf0b /default.nix
parent5c3ac08fcfd5efdc7240c7a4ca99ad1e013e4d45 (diff)
feat(build): Add top-level package index file r/4
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000000..a95d0e0f4d
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,17 @@
+# This file sets up the top-level package set by merging all local
+# packages into the nixpkgs top-level.
+
+let
+  localPkgs = super: pkgs: {
+    tazjin.tazblog = import ./services/tazblog { inherit pkgs; };
+  };
+
+  # TODO(tazjin): It might be preferable to pin a specific commit of
+  # nixpkgs, but for now the assumption will be that a single release
+  # channel is reasonably stable.
+  nixpkgsVersion = "nixos-19.03";
+  nixpkgs = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsVersion}.tar.gz";
+
+in import (builtins.fetchTarball nixpkgs) {
+    overlays = [ localPkgs ];
+}