about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-01T15·37+0300
committerclbot <clbot@tvl.fyi>2022-01-02T22·25+0000
commit4ab061ed988577fcb64e8927b2331346202ee32c (patch)
treecb6abb62e69ebbe91bb6dc95c23dbc1baad38d80 /default.nix
parent5a6f984222d37e50c8d7c06415ba48e66f45b4ed (diff)
fix(ops/pipelines): Realise anchor derivation for rooting r/3512
Turns the anchor derivation into something that can actually be
built (a call creating a propagated build inputs file), and builds it.

This should fix the anchoring logic we have on canon.

Change-Id: If6a7662b82e2e396388980f65e332cf67a45b46e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4763
Tested-by: BuildkiteCI
Autosubmit: tazjin <mail@tazj.in>
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index fd02dfbde9..1cf62e94af 100644
--- a/default.nix
+++ b/default.nix
@@ -108,8 +108,8 @@ in readTree.fix(self: (readDepot {
   });
 
   # Derivation that gcroots all depot targets.
-  ci.gcroot = self.third_party.nixpkgs.symlinkJoin {
+  ci.gcroot = with self.third_party.nixpkgs; makeSetupHook {
     name = "depot-gcroot";
-    paths = self.ci.targets;
-  };
+    deps = self.ci.targets;
+  } emptyFile;
 })