about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-19T15·35+0000
committerVincent Ambo <tazjin@google.com>2019-12-19T15·38+0000
commit124d26210bf850d0eb7a627a1f09fbafaeed702a (patch)
tree4adf12dbf6afc6b8b691547ce67bad99b8cf26e5 /default.nix
parent467a66bac27e85b7e1fcd1b6ebf205481a8de8d6 (diff)
chore(build): Add package required for buildGo at the top-level r/204
This is required to maintain buildGo compatibility with non-depot
setups.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 4c54d15646..38de1be0de 100644
--- a/default.nix
+++ b/default.nix
@@ -70,4 +70,13 @@ in fix(self: {
     runCommand
     symlinkJoin
     writeText;
-})
+}
+
+# These packages must be exposed for compatibility with buildGo.
+#
+# Despite buildGo being tracked in this tree, I want it to be possible
+# for external users to import it with the default nixpkgs layout.
+// {
+  inherit (self.third_party) go ripgrep;
+}
+)