about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-16T12·55+0300
committertazjin <tazjin@tvl.su>2022-01-17T11·49+0000
commit0779f96687cb66d7b4948861804dc36dec9dcb7e (patch)
tree14b82f874988441f501e429add1a2d4b78cb3d21 /default.nix
parent0a21da2bb4db308d8cf01f454e7b9c3a01b8947f (diff)
feat(nix/buildkite): Check target map of parent to determine skips r/3602
This changes the logic for build pipeline generation to inspect
an (optional) parentTargetMap attribute which contains the derivation
map of a target commit.

Targets that existed in a parent commit with the same drv hash will be
skipped, as they are not considered to have changed.

This does not yet wire up any logic for retrieving the target map from
storage, meaning that at this commit all targets are always built.

The intention is that we will have logic to fetch the target
map (initially from Buildkite artefact storage), which we then pass to
the depot via externalArgs when actually generating the pipeline.

Change-Id: I3373c60aaf4b56b94c6ab64e2e5eef68dea9287c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4946
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 1cf62e94af..db2c503559 100644
--- a/default.nix
+++ b/default.nix
@@ -2,7 +2,9 @@
 # (see //nix/readTree for details) and constructing a matching attribute set
 # tree.
 
-{ nixpkgsBisectPath ? null, nixpkgsConfig ? {}, ... }@args:
+{ nixpkgsBisectPath ? null
+, parentTargetMap ? null
+, nixpkgsConfig ? {}, ... }@args:
 
 let
   inherit (builtins)