about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-23T22·32+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-01T22·32+0000
commit6249e19cdc2a44664e7b06d35ff0af91eca640b9 (patch)
tree8140a54efea69a0f18b997f5278988522734ecbc /default.nix
parent9e0fdd397382da10a8486d25cfa9d889fdd17f86 (diff)
Add nixos as top-level monorepo package
I'd like to be able to call...
`nix-build -E '(import <briefcase> {}).nixos.socrates'`
...as part of my efforts to wane my dependence off of `nixos-rebuild`.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 8b973bd2d22d..861ae6beee6f 100644
--- a/default.nix
+++ b/default.nix
@@ -21,6 +21,7 @@ let
   # TODO: Find a better way to expose entire monorepo without introducing
   # "infinite recursion".
   localPkgs = readTree: {
+    nixos = readTree ./nixos;
     blog = readTree ./blog;
     lisp = readTree ./lisp;
     gopkgs = readTree ./gopkgs;