about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-07-06T13·22+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-07-06T13·22+0100
commit359f376005836bf57018fbcf2a6e98a79e1a7a17 (patch)
tree971b619db06a777a4ec1b9be187c284836d9af5d /default.nix
parent7d9cfdbc41c664054963184487907032932c870a (diff)
Add ref attribute to fetchGit
Because revs afa9ca, dc80d7 aren't in the "default" (typically "master") branch
of NixOS/nixpkgs-channels, I need to specify the ref (aka branch) in order for
fetchGit to resolve the rev.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/default.nix b/default.nix
index 9c8c711ef7c4..bfc1d4015cf8 100644
--- a/default.nix
+++ b/default.nix
@@ -5,14 +5,16 @@ let
     url = "https://cl.tvl.fyi/depot";
     rev = "a2e86152401c7c531801c79347c3f15e1806aabc";
   }) {};
-  readTree = depot.readTree {
+  readTree = depot.nix.readTree {
     pkgs = import (builtins.fetchGit {
-      url = "https://github.com/NixOS/nixpkgs";
-      rev = "f1a79c86358c5464c64b4fad00fca07a10e62a74";
+      url = "https://github.com/NixOS/nixpkgs-channels";
+      ref = "nixos-20.03";
+      rev = "afa9ca61924f05aacfe495a7ad0fd84709d236cc";
     }) {};
     unstable = import (builtins.fetchGit {
-      url = "https://github.com/NixOS/nixpkgs";
-      rev = "b3251e04ee470c20f81e75d5a6080ba92dc7ed3f";
+      url = "https://github.com/NixOS/nixpkgs-channels";
+      ref = "nixos-unstable";
+      rev = "dc80d7bc4a244120b3d766746c41c0d9c5f81dfa";
     }) {};
     briefcase = import (builtins.path {
       path = ./.;