about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-01-03T15·54+0100
committerVincent Ambo <tazjin@gmail.com>2018-01-03T15·54+0100
commit0d7f845bf5e54f2af6bda4cdf9476bcd66ff08d4 (patch)
tree2f58992f97d6bb5eba7d3ebaf18602a663e1b9b2 /default.nix
parentcc6de0f9c6792413a58031b74190ad358a2b6efd (diff)
refactor(build): Use ASDF facility for output naming
Turns out there is an easy-to-use :build-pathname parameter to set the
output binary name. This kills the hack!
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index f4a10b5426..43950571c5 100644
--- a/default.nix
+++ b/default.nix
@@ -23,7 +23,7 @@ stdenv.mkDerivation rec {
   #
   # 3. Build (and don't strip!) an executable out of the Lisp backend.
   buildPhase = ''
-    mkdir -p $out/share/gemma $out/bin $src/build
+    mkdir -p $out/share/gemma $out/bin
     mkdir .home && export HOME="$PWD/.home"
 
     # Build Elm
@@ -35,9 +35,8 @@ stdenv.mkDerivation rec {
     quicklisp init
     sbcl --load build.lisp
 
-    # ASDF writes this output into an extremely annoying path, but I also can't
-    # be bothered to figure out the output-translation definition for it.
-    mv $HOME/.cache/common-lisp/sbcl-*/$PWD/build/gemma $out/bin/gemma
+    # "Install" result
+    cp $src/gemma $out/bin/gemma
   '';
 
   installPhase = "true";