about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2018-06-15T14·47+0200
committerVincent Ambo <mail@tazj.in>2018-06-15T14·47+0200
commit7258f31d29bb3728fa0d4d0ec197e2e5624cb57d (patch)
tree23b7b2f1f990d4bd201a82b983201d848c9f9b85 /default.nix
parent4ef98fc2ba0f3007adcf2a8ab128ccecfcbba212 (diff)
feat(build): Add initial Nix build derivation
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000000..f07dbf7f6c
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,16 @@
+# Nix derivation to build a release version of journaldriver.
+#
+# Note: This does not currently use Carnix due to an issue with
+# linking against the `systemd.dev` derivation for libsystemd.
+
+{ pkgs ? import <nixpkgs> {}}:
+
+with pkgs; rustPlatform.buildRustPackage {
+  name        = "journaldriver";
+  version     = "0.1.0";
+  cargoSha256 = "05iwidi66f0lssbkgn13rnvlqmajdbdp859wv2a1xqvi8fcpqsmy";
+
+  src = ./.;
+
+  buildInputs = [ pkgconfig openssl systemd.dev ];
+}