about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-23T21·58+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-23T22·01+0000
commit6108f8df0140e2f71c9f9b50d530d16400d9cdcb (patch)
tree8d1fcc3c535cf9e449ec1d114d407391b3ee1de8 /default.nix
parent2e3bb0435f2849e2a5d4da0ed8408c2993ca9052 (diff)
Support proof-of-concept blog
After some toil, I have a working proof-of-concept blog. The idea is simple:
write blog posts in markdown and store the posts in the `./posts`
directory. Then use the server and `pandoc` to convert these markdown files into
HTML at request time. I'm using nix to package everything together. It's far
from perfect, but it works at the moment, which is encouraging.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index d1fb88e04f93..ff31279941ae 100644
--- a/default.nix
+++ b/default.nix
@@ -15,8 +15,11 @@ let
 
   readTree' = import /home/wpcarro/depot/nix/readTree {};
 
+  # TODO: Find a better way to expose entire monorepo without introducing
+  # "infinite recursion".
   localPkgs = readTree: {
-    third_party   = readTree ./third_party;
+    blog = readTree ./blog;
+    third_party = readTree ./third_party;
   };
 in fix(self: {
   config = config self;