about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-08-21T10·12+0100
committerWilliam Carroll <wpcarro@gmail.com>2020-08-21T10·12+0100
commit3f3cba7c320a78b554e47c179c078ad790257065 (patch)
tree140ae2579e1bb777fb39c08a56876816bcae03e2 /default.nix
parent13daa560ba83c5a1c8e6785ebc47c0086225461b (diff)
Define BuildKite pipelines in Nix
After a handful of failed attempts to run lint-secrets.sh due to a missing
`git-secrets` executable on my git server, I decided that now was a good time to
use Nix to define my BuildKite pipelines.

TL;DR:
- Delete ci/scripts directory
- Define ci/pipelines/{briefcase,socrates}.nix

Outside of this repository:
- I logged into my admin account at git.wpcarro.dev and changed my Gitea
  post-receive hook to trigger the briefcase pipeline
- I logged into my BuildKite account, deleted my build-briefcase pipeline,
  created a new briefcase pipeline that called:

  ```shell
  nix-build -A ci.pipelines.briefcase -o briefcase.yaml
  buildkite-agent pipeline upload briefcase.yaml
  ```

One day I will audit all of my ad-hoc, non-mono-repo activity (like the steps I
listed above) and attempt to fit everything herein... one step at a time,
though!
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 55bb447a5c..0df52cce6a 100644
--- a/default.nix
+++ b/default.nix
@@ -18,6 +18,7 @@ let
     depot = depot;
   };
 in {
+  ci           = readTree ./ci;
   nixos        = readTree ./nixos;
   utils        = readTree ./utils;
   emacs        = readTree ./emacs;