about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-21T00·59+0000
committerVincent Ambo <tazjin@google.com>2019-12-21T00·59+0000
commit28200fb0598cd16d614c541613d3fb2f426dff30 (patch)
tree0f5fd35429febef30faa7a89ada585cd326937d7 /default.nix
parentdfc1ead29df581b80a69f857e706512600768f4b (diff)
chore(bootstrapping-2018): Prepare for depot merge
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/default.nix b/default.nix
deleted file mode 100644
index c4ac8a472a..0000000000
--- a/default.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-# This derivation builds the LaTeX presentation.
-
-{ pkgs ? import <nixpkgs> {} }:
-
-with pkgs; let tex = texlive.combine {
-  inherit (texlive)
-    beamer
-    beamertheme-metropolis
-    etoolbox
-    euenc
-    extsizes
-    fontspec
-    lualibs
-    luaotfload
-    luatex
-    luatex-def
-    minted
-    ms
-    pgfopts
-    scheme-basic;
-};
-in stdenv.mkDerivation {
-  name = "nuug-reproducible-slides.pdf";
-  src = ./.;
-
-  FONTCONFIG_FILE = makeFontsConf {
-    fontDirectories = [ fira fira-code fira-mono ];
-  };
-
-  buildInputs = [ tex fira fira-code fira-mono ];
-  buildPhase = ''
-    # LaTeX needs a cache folder in /home/ ...
-    mkdir home
-    export HOME=$PWD/home
-    # ${tex}/bin/luaotfload-tool -ufv
-
-    # As usual, TeX needs to be run twice ...
-    function run() {
-      ${tex}/bin/lualatex presentation.tex
-    }
-    run && run
-  '';
-
-  installPhase = ''
-    cp presentation.pdf $out
-  '';
-}