about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2019-08-25T17·28-0400
committerGriffin Smith <root@gws.fyi>2019-08-25T17·28-0400
commitd3f3890dc5408581eb6181125c871d1cf2c0e18f (patch)
treeed6d9e396e6c732b1bce27ea6962ce408b59f218 /default.nix
parentfb0d1b3e66251aa56a3df1d05fd4b82b33380a31 (diff)
An @-sign in a box, in haskell
Initial commit of a Haskell version of Xanthous, written using Brick and
built with Nix.

This is so much nicer and so much easier
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000000..f73c537abd
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,8 @@
+{ nixpkgs ? import <nixpkgs> {}, compiler ? "ghc865" }:
+let
+  inherit (nixpkgs) pkgs;
+  all-hies = import (fetchTarball "https://github.com/infinisil/all-hies/tarball/master") {};
+  hie = all-hies.selection { selector = p: { inherit (p) ghc865; }; };
+  xanthous = pkgs.haskellPackages.callPackage ./xanthous.nix {};
+in
+xanthous // { inherit hie; }