about summary refs log tree commit diff
path: root/deepmind/part_two/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-11T17·07+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-11T17·11+0000
commit85cdd46f0082afb8ed09dcb0983071daa6bde38c (patch)
tree0c18373982f3621b3a5408690faf4f5de6443d33 /deepmind/part_two/shell.nix
parent3afb56a5e5274611c3c5d0f7e2f4a8965575ff40 (diff)
Attempt to support TypeScript for coding challenges
I was a bit weaker than I expected to be in my most recent interview using
TypeScript. To improve, I think I'd like to attempt solving some of the
InterviewCake.com questions using TypeScript.

If you've read the previous commits, the inspiration for `run` arose because I
need to call `npx ts-code <file>`, which is easy enough to remember, but I'd
still rather just call `run <file>`.
Diffstat (limited to 'deepmind/part_two/shell.nix')
-rw-r--r--deepmind/part_two/shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/deepmind/part_two/shell.nix b/deepmind/part_two/shell.nix
new file mode 100644
index 0000000000..606dd7167f
--- /dev/null
+++ b/deepmind/part_two/shell.nix
@@ -0,0 +1,10 @@
+{ pkgs ? import <nixpkgs> {}, ... }:
+
+pkgs.mkShell {
+  buildInputs = with pkgs; [
+    nodejs
+    python3
+    go
+    goimports
+  ];
+}