about summary refs log tree commit diff
path: root/covid-uk/shell.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-18T21·29+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-18T22·08+0000
commitdd9788fa7311ad7722f68f30f31c6aa472c99f07 (patch)
treebf49d286592fbd01dbbb40831da982c7df2b2170 /covid-uk/shell.nix
parent79b5fce68a6e4c0a190f69b319b8e4f46ede3f91 (diff)
Create line chart of UK confirmed corona virus cases
I was having trouble tracking the growth of corona virus cases in the UK.
Thankfully someone is publishing some daily COVID data as JSON. I downloaded
that data manually and plotted it using the chart.js library as a programming
exercise with Mimi.

Now I'm attempting to deploy to https://wpcarro.dev/covid-uk.

TODO(wpcarro): Prefer the live API data instead my soon-to-be-stale downloaded.
Diffstat (limited to 'covid-uk/shell.nix')
-rw-r--r--covid-uk/shell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/covid-uk/shell.nix b/covid-uk/shell.nix
new file mode 100644
index 000000000000..38df7d4e8508
--- /dev/null
+++ b/covid-uk/shell.nix
@@ -0,0 +1,8 @@
+let
+  pkgs = import <nixpkgs> {};
+in pkgs.mkShell {
+  buildInputs = with pkgs; [
+    yarn
+    nodejs
+  ];
+}