about summary refs log tree commit diff
path: root/covid-uk/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-03-18T21·29+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-03-18T22·08+0000
commitdd9788fa7311ad7722f68f30f31c6aa472c99f07 (patch)
treebf49d286592fbd01dbbb40831da982c7df2b2170 /covid-uk/default.nix
parent79b5fce68a6e4c0a190f69b319b8e4f46ede3f91 (diff)
Create line chart of UK confirmed corona virus cases
I was having trouble tracking the growth of corona virus cases in the UK.
Thankfully someone is publishing some daily COVID data as JSON. I downloaded
that data manually and plotted it using the chart.js library as a programming
exercise with Mimi.

Now I'm attempting to deploy to https://wpcarro.dev/covid-uk.

TODO(wpcarro): Prefer the live API data instead my soon-to-be-stale downloaded.
Diffstat (limited to 'covid-uk/default.nix')
-rw-r--r--covid-uk/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/covid-uk/default.nix b/covid-uk/default.nix
new file mode 100644
index 000000000000..5189daddf28a
--- /dev/null
+++ b/covid-uk/default.nix
@@ -0,0 +1,14 @@
+{ pkgs, ... }:
+
+pkgs.stdenv.mkDerivation {
+  name = "covid-uk";
+  buildInputs = [];
+  src = ./.;
+  buildPhase = ''
+    mkdir -p $out
+    mkdir -p $out/node_modules/chart.js/dist
+    cp $src/node_modules/chart.js/dist/Chart.bundle.min.js $out/node_modules/chart.js/dist
+    cp $src/src/* $out
+  '';
+  dontInstall = true;
+}