about summary refs log tree commit diff
path: root/corp/tvixbolt/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-09-18T09·59+0300
committertazjin <tazjin@tvl.su>2022-09-18T16·40+0000
commit993c22de5990a6522794647522b221f4fde6c770 (patch)
treeb0d6510cb2e9eee4c9821d3a16dbf75c3dc2231f /corp/tvixbolt/Cargo.toml
parentd431aa7743f0956cd31ab64b73bbee469783ba51 (diff)
chore(corp/tvixbolt): add yew-router dependency r/4899
This will be used to set/get query parameters for making shareable links.

Change-Id: I05ccf8cab2521564710523ccd3b25ec26f435dd5
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6633
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to '')
-rw-r--r--corp/tvixbolt/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/corp/tvixbolt/Cargo.toml b/corp/tvixbolt/Cargo.toml
index 7d259c20b2..57eea8e126 100644
--- a/corp/tvixbolt/Cargo.toml
+++ b/corp/tvixbolt/Cargo.toml
@@ -7,8 +7,10 @@ edition = "2021"
 
 [dependencies]
 yew = "0.19.3"
+yew-router = "0.16"
 codemap = "0.1.3"
-web-sys = "*"
+serde_urlencoded = "*" # pinned by yew
+web-sys = "*" # pinned by yew
 
 # needs to be in sync with nixpkgs
 wasm-bindgen = "= 0.2.82"