about summary refs log tree commit diff
path: root/corp/tvixbolt/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-10-13T16·20+0300
committertazjin <tazjin@tvl.su>2022-10-16T12·26+0000
commita8f7383fcb151f76c9cda1235abf0577b1ce6720 (patch)
treeb3a11ef832314510df8cabee54a97d511a572fee /corp/tvixbolt/Cargo.toml
parente6d9be32a2dc6c7752f658f5c8fe4e33024bc2d3 (diff)
refactor(tvixbolt): use details elements for toggling outputs r/5145
For optional outputs (runtime trace & AST) this has a slightly nicer
user experience.

Note that the code of this is a bit verbose because doing a naive
implementation hits dumb behaviours of browsers that result in
infinite loops.

Thanks Profpatsch for the suggestion.

Change-Id: I8945a8e722f0ad8735829807fb5e39e2101f378c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7006
Reviewed-by: j4m3s <james.landrein@gmail.com>
Autosubmit: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'corp/tvixbolt/Cargo.toml')
-rw-r--r--corp/tvixbolt/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/corp/tvixbolt/Cargo.toml b/corp/tvixbolt/Cargo.toml
index c448f9fe42..7182e88d83 100644
--- a/corp/tvixbolt/Cargo.toml
+++ b/corp/tvixbolt/Cargo.toml
@@ -10,7 +10,6 @@ yew = "0.19.3"
 yew-router = "0.16"
 codemap = "0.1.3"
 serde_urlencoded = "*" # pinned by yew
-web-sys = "*" # pinned by yew
 
 # needs to be in sync with nixpkgs
 wasm-bindgen = "= 0.2.83"
@@ -26,3 +25,7 @@ default-features = false
 [dependencies.serde]
 version = "*" # pinned by yew
 features = [ "derive" ]
+
+[dependencies.web-sys]
+version = "*" # pinned by yew
+features = [ "HtmlDetailsElement" ]