about summary refs log tree commit diff
path: root/corp/tvixbolt/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-09-04T12·16+0300
committertazjin <tazjin@tvl.su>2022-09-04T14·05+0000
commit8655440ae3f42543ad5d2a980cef389529867f4b (patch)
treebf943e3dd6029b613564b1cf34bf52051aaf712d /corp/tvixbolt/Cargo.toml
parentf88d248f483af0cf1b83152367376b6b90893aac (diff)
feat(corp/tvixbolt): check in initial tvixbolt version r/4630
This is the code backing the small site currently deployed at
https://tazj.in/blobs/nixbolt/index.html

This relies on a newer version of Tvix than is available in depot and
a bunch of other stuff that isn't public yet, so for now no build file
is provided as this is heavily work-in-progress.

Change-Id: I7a8e4dbf4e11d1c70175f929e65f40ff69acbbd9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6315
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'corp/tvixbolt/Cargo.toml')
-rw-r--r--corp/tvixbolt/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/corp/tvixbolt/Cargo.toml b/corp/tvixbolt/Cargo.toml
new file mode 100644
index 0000000000..123d49e109
--- /dev/null
+++ b/corp/tvixbolt/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "tvixbolt"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+yew = "0.19.3"
+codemap = "0.1.3"
+web-sys = "*"
+
+[dependencies.rnix]
+git = "https://github.com/nix-community/rnix-parser.git"
+rev = "97b438e34be5211a4b48aeed9cc3ded489b4d6da"
+
+[dependencies.tvix-eval]
+path = "../tvix-eval/tvix/eval"
+default-features = false
+features = [ "disassembler" ]