about summary refs log tree commit diff
path: root/corp/russian/data-import/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-01-17T21·36+0300
committertazjin <tazjin@tvl.su>2023-01-18T01·10+0000
commitee7616d9563eabf2ae01927bc9d37ccf3e3b3325 (patch)
treeac43dc06b1f191308182897bd46726f5e9d41783 /corp/russian/data-import/Cargo.toml
parent032ab16bbbd318704be71af7b569624ddab24802 (diff)
feat(corp/russian/data-import): new OpenCorpora data import tool r/5683
Adds the beginning of a tool which can import OpenCorpora data into a
SQLite database. This is quite a lot of toil and there's probably a
better way to do this, but overall becoming this intimately familiar
with the data structures is quite helpful for understanding what I
can/can't do with only this dataset.

Change-Id: Ieab33a8ce07ea4ac87917b9c8132226bbc6523b1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7859
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'corp/russian/data-import/Cargo.toml')
-rw-r--r--corp/russian/data-import/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/corp/russian/data-import/Cargo.toml b/corp/russian/data-import/Cargo.toml
new file mode 100644
index 000000000000..b43f829f37b0
--- /dev/null
+++ b/corp/russian/data-import/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "data-import"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+env_logger = "0.10.0"
+log = "0.4.17"
+rusqlite = "0.28"
+xml-rs = "0.8"
+
+[profile.release-with-debug]
+inherits = "release"
+debug = true