about summary refs log tree commit diff
path: root/corp/russian/data-import/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-01-20T10·31+0300
committertazjin <tazjin@tvl.su>2023-01-21T17·49+0000
commit429c0d00c4cd07ea90c85bf1ec2f2c742d970420 (patch)
tree85103dcdf8b7c9d30552dfc97321ad99d77ff2e3 /corp/russian/data-import/Cargo.toml
parentee0c0ee95103fa10e227a1976149d20e6944001c (diff)
feat(corp/data-import): add import of OpenRussian 'words' table r/5729
This is actually the lemmata table of this corpus, not the forms of
all words (they're in a separate table).

Change-Id: I89a2c2817ccce840f47406fa2a636f4ed3f49154
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7893
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'corp/russian/data-import/Cargo.toml')
-rw-r--r--corp/russian/data-import/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/corp/russian/data-import/Cargo.toml b/corp/russian/data-import/Cargo.toml
index b43f829f37b0..1aae2e830578 100644
--- a/corp/russian/data-import/Cargo.toml
+++ b/corp/russian/data-import/Cargo.toml
@@ -6,9 +6,11 @@ edition = "2021"
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dependencies]
+csv = "1.1"
 env_logger = "0.10.0"
 log = "0.4.17"
 rusqlite = "0.28"
+serde = { version = "1.0", features = ["derive"] }
 xml-rs = "0.8"
 
 [profile.release-with-debug]