about summary refs log tree commit diff
path: root/corp/rih/frontend/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-06-09T12·52+0300
committertazjin <tazjin@tvl.su>2023-06-10T11·23+0000
commita970de336574e046e63763d93f9a70d5b1e8464b (patch)
treea700d4c1a983bd4a4be24b50c84d39351c732fdb /corp/rih/frontend/Cargo.toml
parentd925ec34cd6625b211c4f5dfe66937d7f3d6a0d6 (diff)
feat(corp/rih): add UUIDs to records from frontend r/6254
This UUID stays the same even if a user submits the form multiple
times (unless they edit it manually in local storage, of course).

Change-Id: I4190fbfeb1027ce8a8d87bc283099539e8722b39
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8733
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'corp/rih/frontend/Cargo.toml')
-rw-r--r--corp/rih/frontend/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/corp/rih/frontend/Cargo.toml b/corp/rih/frontend/Cargo.toml
index 1ef53bb5d3..2f58274566 100644
--- a/corp/rih/frontend/Cargo.toml
+++ b/corp/rih/frontend/Cargo.toml
@@ -20,6 +20,7 @@ wasm-bindgen-futures = "0.4"
 
 # needs to be in sync with nixpkgs
 wasm-bindgen = "= 0.2.84"
+uuid = { version = "1.3.3", features = ["v4", "serde"] }
 
 [dependencies.serde]
 version = "*" # pinned by yew