about summary refs log tree commit diff
path: root/corp/rih/backend/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-06-06T11·35+0300
committertazjin <tazjin@tvl.su>2023-06-06T11·43+0000
commit896034cc94b09d6efc1eba6bb2fdad03269ff369 (patch)
treecef7bdae0aa2963658bc4410a700b0bd37b1cacb /corp/rih/backend/default.nix
parent5dee4780dab5e22eb2929a3b4287c5a781fc20f9 (diff)
chore(corp/rih): bootstrap backend application with rouille r/6238
Change-Id: I48b0c432a843db5a44b3a3de09f18e1232644a44
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8715
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to 'corp/rih/backend/default.nix')
-rw-r--r--corp/rih/backend/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/corp/rih/backend/default.nix b/corp/rih/backend/default.nix
new file mode 100644
index 0000000000..802479e509
--- /dev/null
+++ b/corp/rih/backend/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, ... }:
+
+depot.nix.readTree.drvTargets rec {
+  binary = depot.third_party.naersk.buildPackage {
+    src = ./.;
+  };
+
+  image = pkgs.dockerTools.buildLayeredImage {
+    name = "rih-backend";
+    config.Cmd = [ "${binary}/bin/rih-backend" ];
+
+    contents = [
+      binary
+    ];
+  };
+}