about summary refs log tree commit diff
path: root/corp/rih/backend/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-06-09T12·08+0300
committertazjin <tazjin@tvl.su>2023-06-09T12·21+0000
commit0ddd4ecd9ddb310b93166620acba33d2065561ca (patch)
tree1b5d42800a465dbd8a9e9d643b4b4db1cd5b4957 /corp/rih/backend/Cargo.toml
parentaea8c79ca384d5d290b138de0f2ba5af8559ee2d (diff)
feat(corp/rih): persist data in storage bucket r/6250
Change-Id: Ide7a21b97e845681584378d348cc36aba951d69f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8730
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'corp/rih/backend/Cargo.toml')
-rw-r--r--corp/rih/backend/Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/corp/rih/backend/Cargo.toml b/corp/rih/backend/Cargo.toml
index d9375d592ddd..f6d2b97b70be 100644
--- a/corp/rih/backend/Cargo.toml
+++ b/corp/rih/backend/Cargo.toml
@@ -3,6 +3,17 @@ name = "rih-backend"
 version = "0.1.0"
 edition = "2021"
 
+[dependencies]
+anyhow = "1.0"
+serde = { version = "1.0", features = [ "derive" ] }
+serde_json = "1.0"
+uuid = { version = "1.3.3", features = ["v4", "serde"] }
+
 [dependencies.rouille]
-version = "3.6.2"
+version = "3.6"
+default-features = false
+
+[dependencies.rust-s3]
+version = "0.33"
 default_features = false
+features = [ "sync-rustls-tls" ]