about summary refs log tree commit diff
path: root/corp/rih/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-06-06T11·26+0300
committertazjin <tazjin@tvl.su>2023-06-06T11·43+0000
commit5dee4780dab5e22eb2929a3b4287c5a781fc20f9 (patch)
treeefdbcdd87bef1bd6dcca3010c0b7115bb443b6de /corp/rih/Cargo.toml
parent6fa6f3a7f4a72a74ce495609646d2dae3789cde3 (diff)
chore(corp/rih): move frontend to a separate folder r/6237
Change-Id: Ic7467f459015c39c73f87c61a048319eaf1243be
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8714
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'corp/rih/Cargo.toml')
-rw-r--r--corp/rih/Cargo.toml41
1 files changed, 0 insertions, 41 deletions
diff --git a/corp/rih/Cargo.toml b/corp/rih/Cargo.toml
deleted file mode 100644
index 1ef53bb5d3f6..000000000000
--- a/corp/rih/Cargo.toml
+++ /dev/null
@@ -1,41 +0,0 @@
-[package]
-version = "0.1.0"
-name = "rih"
-authors = [ "Vincent Ambo <tazjin@tvl.su>" ]
-license = "Proprietary"
-edition = "2021"
-
-[dependencies]
-fuzzy-matcher = "0.3.7"
-getrandom = { version = "0.2", features = ["js"] }
-gloo = "0.8"
-js-sys = "0.3"
-rand = "0.8"
-rust_iso3166 = "0.1.10"
-serde_json = "1.0"
-serde_urlencoded = "*" # pinned by yew
-yew = { version = "0.20", features = ["csr"] }
-yew-router = "0.17"
-wasm-bindgen-futures = "0.4"
-
-# needs to be in sync with nixpkgs
-wasm-bindgen = "= 0.2.84"
-
-[dependencies.serde]
-version = "*" # pinned by yew
-features = [ "derive" ]
-
-[dependencies.web-sys]
-version = "*" # pinned by yew
-features = [ "HtmlDetailsElement" ]
-
-[dependencies.static_markdown]
-path = "./static-markdown"
-
-[profile.release]
-lto = true
-opt-level = 'z'
-codegen-units = 1
-
-[package.metadata.wasm-pack.profile.release]
-wasm-opt = ['-Os']