about summary refs log tree commit diff
path: root/corp/rih/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-06-02T09·48+0300
committertazjin <tazjin@tvl.su>2023-06-06T11·43+0000
commit6f0ddbac06a9a72908b8b0b955cd743d3ae82378 (patch)
tree9092b069b2c07ff037e3dc3d839b2e50d2b81fe1 /corp/rih/Cargo.toml
parentb2ff63586acbdcd8e1c8159cac2c09724306eda6 (diff)
feat(corp/rih): display & load captcha element inside the form r/6233
Change-Id: Ifd0f85d9e4f785c4cb1ae56ae67e6d999ff43c85
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8694
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'corp/rih/Cargo.toml')
-rw-r--r--corp/rih/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/corp/rih/Cargo.toml b/corp/rih/Cargo.toml
index 16221b7a55..2dd8cb7b97 100644
--- a/corp/rih/Cargo.toml
+++ b/corp/rih/Cargo.toml
@@ -7,14 +7,15 @@ edition = "2021"
 
 [dependencies]
 fuzzy-matcher = "0.3.7"
+getrandom = { version = "0.2", features = ["js"] }
 gloo = "0.8"
+js-sys = "0.3"
+rand = "0.8"
 rust_iso3166 = "0.1.10"
 serde_json = "1.0"
 serde_urlencoded = "*" # pinned by yew
 yew = { version = "0.20", features = ["csr"] }
 yew-router = "0.17"
-rand = "0.8"
-getrandom = { version = "0.2", features = ["js"] }
 
 # needs to be in sync with nixpkgs
 wasm-bindgen = "= 0.2.84"