about summary refs log tree commit diff
path: root/corepkgs/nar
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-08-07T18·22+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-08-07T18·22+0000
commit5a6b45e2523c29c215f77135c6866baa83f1a7d5 (patch)
tree21423725196659580060186934604f3b1e31f90a /corepkgs/nar
parenta61129c48cfc11f1b836f42e178aaf231c1fed82 (diff)
* In nar.nix, path -> storePath, otherwise we get a collision between
  environment variable names on Cygwin (where they are case
  insensitive).

Diffstat (limited to 'corepkgs/nar')
-rw-r--r--corepkgs/nar/nar.nix6
-rw-r--r--corepkgs/nar/nar.sh.in4
2 files changed, 6 insertions, 4 deletions
diff --git a/corepkgs/nar/nar.nix b/corepkgs/nar/nar.nix
index e0d4878bf4f3..da63bde9a62e 100644
--- a/corepkgs/nar/nar.nix
+++ b/corepkgs/nar/nar.nix
@@ -1,5 +1,7 @@
-{system, path, hashAlgo}: derivation {
+{system, storePath, hashAlgo}: 
+
+derivation {
   name = "nar";
   builder = ./nar.sh;
-  inherit system path hashAlgo;
+  inherit system storePath hashAlgo;
 }
diff --git a/corepkgs/nar/nar.sh.in b/corepkgs/nar/nar.sh.in
index caa960877b4b..67933ac67f0b 100644
--- a/corepkgs/nar/nar.sh.in
+++ b/corepkgs/nar/nar.sh.in
@@ -1,9 +1,9 @@
 #! @shell@ -e
 
-echo "packing $path into $out..."
+echo "packing $storePath into $out..."
 @coreutils@/mkdir $out
 dst=$out/tmp.nar.bz2
-@bindir@/nix-store --dump "$path" > tmp
+@bindir@/nix-store --dump "$storePath" > tmp
 
 @bzip2@ < tmp > $dst